Couldn't find what you looking for?

TRY OUR SEARCH!

Please, please give me some advice or input.  It's killing me.

Here's my situation.

I've been on birth control (TriNessa) for 4 years now.  It's always been normal.  My period has always started on the 3rd or 4th placebo pill day and lasted for about 6 days.  Always.

This past month, I've been having menstrual like cramps, so I had a pelvic ultrasound.  I think they were checking for cysts.  It came back negative.  The next day I had some spotting.  I know this can be common with a transvaginal ultrasound.  However, the 'spotting' started on a Thursday (which would have been exactly 5 days before my period usually starts), and I still have it today which is Sunday.  It's been super light to the point where I could pretty much get by with a pantyliner.  Sometimes it's brown discharge, other times it's just very light pink.  Twice it's been just a bit redder, but not too much more.

I'm afraid that I might be pregnant and that this could be implantation bleeding?  Otherwise, my period just started a week early, which in itself is kind of scary.  Could my birth control be starting to become less effective?

Any advice?  Anyone ever have a situation like this?

Loading...

How long does your pink discharge last before you get your actual period ?
Reply

Loading...

I had the same symptoms, but there were a couple things I needed to consider.
1. This is the first period I had since I quit smoking.
2. I had accidentally skipped a pill here and there. I hadn’t previous done that.
Reply

Loading...