Couldn't find what you looking for?

TRY OUR SEARCH!

I am a mother of 3. I had my last son on August 9th and had my tubes tied the same day. I bled for about a month, after that I had intercourse. The next month I had brown discharge for a few days then started my period, it seemed to be the same for November, so I thought December would be the same, except for I had the brown discharge and no period afterwards. I had intercourse for new years eve night afterwards I had light pink discharge, then sex again on new years and the same light pink discharge.  I took 2 pregnancy test and both came back negative.  I called my doctor the next day and she suggested it might be too early to start my period since I had the spotting the month before. To monitor it for the next month and if I don't start my cycle by the 15th to call back.  I had started about two days later and it lasted for about 3 days which isn't normal for me.  Then about a week later I had intercourse again and a couple days after that I had brown discharge. Then had intercourse again and didn't have anything. Can anyone tell me whats going on and should I be worried? Theres no odor, no itching and no pain with the discharge.

Loading...

I would like to add a pap after having my baby and everything came back normal. So I'm not worried about an STD.
Reply

Loading...

I'm having the same I had my baby 4 mnths ago and it started 1mnth later n still going on
Reply

Loading...

It could just be trying to cleanse itself?
Reply

Loading...