Couldn't find what you looking for?

TRY OUR SEARCH!

Hello, I have always had fairly irregular periods. I am extremely fertile. I'm 38. I had a tubal ligation 5.5 yrs. ago. I ovulated 12-14 days ago. My query is about my last period. I experienced a full day of brown discharge, only visible when wiping. This was followed by a full day of spotting, what appeared to be period blood. Followed now, by what appears to be reg. period flow. I don't believe I am pregnant, just wondering if it is possible that I experienced implantation bleeding. I've only seen this discharge with my pregnancies. There are a few other early warning signs, no breast tenderness. Thanks

Loading...

I've had the same thing going on. I had some very light brown spotting after cramping and passing a large clot of tissue, then an
abnormally light period. I'm 36, had my tubes tied in 1994. I also have had very sore breasts, seems to have gotten worse, not better in the last few days, slight nausea, very tired. I just don't feel right. I've also been dizzy, and off balance. Any ideas?
Reply

Loading...

Hi I know it's 2017 but I was wondering is anyone still interested on this answer bc I'm 27 and have had a tubal since 2011. I was 21 so almost 6 years in Nov. Am having the same problem sore breast, brown spotting only when wiping, I usually only see this after my cycle. Having problems with my insurance so and thing helpful would be great otherwise doc appt it is! Thank you
Reply

Loading...

I’m 24 I’ve always had regular periods. I have 4 kids, all c sections, ages 8, 4, 2, almost 1. I got my tubes tied (doc said he cut tied and burned t make sure I wouldn’t get pregnant because I’ve had 4 c sections) and since I’ve had irregular periods. I didn’t have a period for 2 months after my last birth. And they’ve also been inconsistent as far as the amount of days apart. Last month I had the brownish discharge in between my periods but only when I wiped. Now this month My period ended on the 6th and yesterday I had pink discharge when I wiped and a chunk of something not round shaped cake out into toilet. Ever since it’s been a brown discharge but a lot of it. I have to wipe 2-3 times just when I pee because there’s so much. I also had bad cramping a few days before this started but I thought it was my bowel moving because sometimes I have issues with that. Now I’m feeling kinda crampy like if I were on my regular cycle
Reply

Loading...

Did you get a follow up? Having the same and curious what it could be!
Reply

Loading...

Same here I don’t know what could it be
Reply

Loading...

If u get an answer please post
Reply

Loading...

I have had the same problem. Except (TMI) a week ago I had some pink thick discharge when whipping, the only other time was when I was pregnant. I had my tubes tied hunt of 2015. I have no medical Ins. I have a HX of CINN 2 as well. It also hurts the last 2 times to have intercourse. :(
Reply

Loading...