Couldn't find what you looking for?

TRY OUR SEARCH!

For the past few months I have been experiencing a buring sensation during sexual intercourse, along with an increase in vaginal discharge. I have tested and its not a yeast infection, there is no milky/cottage chesse discharge. At first i thought it was a yeast infection because I have had 2-3 of them this year so far. I have been with my partner for over 4yrs now, and the burning has never happened until this past may ( about 4months ago). We have tryed lubricant condoms and non lubricant,latex and latex free and no condom at all. We have tryed extra lubricant, along with more foreplay. We have even tryed to stretch me out for 5-10min before we had sex. Nothing is working! I only feel the buring when we are having sex. My partner is quiet large, but that has never been a problem.It has always hurt a lil when entering but never like this. I am on birth control the Nuvaring, and just started using it this past January. But in the past I have used the Nuvaring and this never occured. I dont know what to do anymore, this is taking a toll on our love life and making me feel really depressed. Someone Help!!!!! PLease!

Loading...

i experienced the same problem but it was a yeast infection..also i was associated with a urinary tract infection.i stop after i took some antibiotics am gud now..hope this helps
Reply

Loading...

i have this issue as well. My doctor has disregarded it and told me to use lube, which we both know doesn't work. :(
Reply

Loading...